import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:https?:\\/\\/)?(?:www\\.)?youtu(?:be)?\\.(?:com|be)(?:\\/watch\\/?\\?v=|\\/embed\\/|\\/shorts\\/|\\/)(\\w+)";
final String string = "https://youtu.be/YOUTUBE_ID?123\n"
+ "https://www.youtube.com/embed/YOUTUBE_ID?123\n"
+ "https://www.youtube.com/watch?v=YOUTUBE_ID?asd\n\n"
+ "https://youtu.be/YOUTUBE_ID&123\n"
+ "https://www.youtube.com/embed/YOUTUBE_ID&123\n"
+ "https://www.youtube.com/watch?v=YOUTUBE_ID&asd\n\n"
+ "https://youtu.be/YOUTUBE_ID/123\n"
+ "https://www.youtube.com/embed/YOUTUBE_ID/123\n"
+ "https://www.youtube.com/watch?v=YOUTUBE_ID/asd\n"
+ "https://youtube.com/shorts/YOUTUBE_ID?feature=share\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}