using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[ktau]{4}\b";
string input = @"[""Rajakatu"",""Lapinlahdenktau"",""Nurmenkaut"",""Linnakoskenkuat""]";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}