$re = '/[ktau]{4}\b/';
$str = '["Rajakatu","Lapinlahdenktau","Nurmenkaut","Linnakoskenkuat"]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);