package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[ktau]{4}\b`)
var str = `["Rajakatu","Lapinlahdenktau","Nurmenkaut","Linnakoskenkuat"]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}