package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\bN[^\W_]{3,6}\b`)
var str = `N and will have combination of 3 to 6 letters or numbers with it ie. N24 or NX747 or N35655V but it should ignore N2 or N8(N plus 1 character) or N1234567(N plus more than 6 characters`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}