use strict;
my $str = 'N and will have combination of 3 to 6 letters or numbers with it ie. N24 or NX747 or N35655V but it should ignore N2 or N8(N plus 1 character) or N1234567(N plus more than 6 characters';
my $regex = qr/\bN[^\W_]{3,6}\b/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}