$re = '/\bN[^\W_]{3,6}\b/';
$str = 'N and will have combination of 3 to 6 letters or numbers with it ie. N24 or NX747 or N35655V but it should ignore N2 or N8(N plus 1 character) or N1234567(N plus more than 6 characters';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);