re = /\bFlorida\b(?!.*\bFlorida\b).*/m
str = 'Arkansas; Hawaii; South Dakota; North Carolina
California;Florida; Washington State; New York; Florida; West Virginia; DC
Nevada; Texas; New Mexico; Georgia'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end