package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b(0?[1-9]|[12][0-9]|3[01])\b`)
var str = `1 01 12 20 31 32 34 998`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}