const regex = /\b(0?[1-9]|[12][0-9]|3[01])\b/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(0?[1-9]|[12][0-9]|3[01])\\b', 'g')
const str = `1 01 12 20 31 32 34 998`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}