$re = '/\b(0?[1-9]|[12][0-9]|3[01])\b/';
$str = '1 01 12 20 31 32 34 998';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);