$re = '/:[^[:alpha:]]*\K[[:alpha:]]+\b/m';
$str = 'Weekend Team: ~ Vincent Smith Operations
Weekend Team: ~ Jana\'ya Smith Operations
Weekend Team: ~ h4cker Smith Operations
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);