re = /:[^[:alpha:]]*\K[[:alpha:]]+\b/m
str = 'Weekend Team: ~ Vincent Smith Operations
Weekend Team: ~ Jana\'ya Smith Operations
Weekend Team: ~ h4cker Smith Operations
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end