package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)[A-ZÑÁÉÍÓÚ\s]+`)
var str = `JUAN MORENO
JULIÁN MARTINEZ
ÑANDO TORRES ORTULIZAN
GULIAN GÚRRAIN`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}