$re = '/[A-ZÑÁÉÍÓÚ\s]+/s';
$str = 'JUAN MORENO
JULIÁN MARTINEZ
ÑANDO TORRES ORTULIZAN
GULIAN GÚRRAIN';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);