import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?(DEFINE)\n"
+ " (?<END>\\n?$|\\n\\n)\n"
+ " (?<LINE>\\n.+)\n"
+ ")\n"
+ "(?<=...).+(?=...(?&END))\n"
+ "|..(?=(?:..|.(?&LINE)|(?&LINE){2}|....(?&LINE){3,})(?&LINE)(?&END))\n"
+ "|(?<=\\n..)..(?=.+(?&LINE)(?&END))\n"
+ "|(?<=\\n.)..(?=.+(?&LINE){2}(?&END))\n"
+ "|(?<=\\n)..(?=.+(?&LINE){3}(?&END))\n"
+ "|(?:(?<=\\n....)|(?<=^....))..(?=.+(?&LINE){4,}(?&END))";
final String string = "aaaaaaaaaaaaaaaaaaaa\n"
+ "aaaaaaaaaaaaaaaaaaaa\n"
+ "aaaaaaaaaaaaaaaaaaaa\n"
+ "aaaaaaaaaaaaaaaaaaaa\n"
+ "aaaaaaaaaaaaaaaaaaaa\n"
+ "aaaaaaaaaaaaaaaaaaaa\n"
+ "aaaaaaaaaaaaaaaaaaaa\n"
+ "aaaaaaaaaaaaaaaaaaaa\n\n"
+ "sdaffdsdfsdsfaadd\n"
+ "afdsafdsfssdsfdfs\n"
+ "afdsfdssdfdssfdsf\n"
+ "asfddsfafsdfdsdsf\n"
+ "asfdsdfafdsafasdf\n\n"
+ "hellohellohellohellohello\n"
+ "hellohellohellohellohello\n"
+ "hellohellohellohellohello\n"
+ "hellohellohellohellohello\n"
+ "hellohellohellohellohello\n"
+ "hellohellohellohellohello\n\n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " ";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}