import re
regex = re.compile(r"""
(?(DEFINE)
(?<END>\n?$|\n\n)
(?<LINE>\n.+)
)
(?<=...).+(?=...(?&END))
|..(?=(?:..|.(?&LINE)|(?&LINE){2}|....(?&LINE){3,})(?&LINE)(?&END))
|(?<=\n..)..(?=.+(?&LINE)(?&END))
|(?<=\n.)..(?=.+(?&LINE){2}(?&END))
|(?<=\n)..(?=.+(?&LINE){3}(?&END))
|(?:(?<=\n....)|(?<=^....))..(?=.+(?&LINE){4,}(?&END))
""", flags=re.VERBOSE)
test_str = ("aaaaaaaaaaaaaaaaaaaa\n"
"aaaaaaaaaaaaaaaaaaaa\n"
"aaaaaaaaaaaaaaaaaaaa\n"
"aaaaaaaaaaaaaaaaaaaa\n"
"aaaaaaaaaaaaaaaaaaaa\n"
"aaaaaaaaaaaaaaaaaaaa\n"
"aaaaaaaaaaaaaaaaaaaa\n"
"aaaaaaaaaaaaaaaaaaaa\n\n"
"sdaffdsdfsdsfaadd\n"
"afdsafdsfssdsfdfs\n"
"afdsfdssdfdssfdsf\n"
"asfddsfafsdfdsdsf\n"
"asfdsdfafdsafasdf\n\n"
"hellohellohellohellohello\n"
"hellohellohellohellohello\n"
"hellohellohellohellohello\n"
"hellohellohellohellohello\n"
"hellohellohellohellohello\n"
"hellohellohellohellohello\n\n"
" \n"
" \n"
" \n"
" \n"
" \n"
" \n"
" ")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")