re = /(?(DEFINE)
(?<END>\n?$|\n\n)
(?<LINE>\n.+)
)
(?<=...).+(?=...(?&END))
|..(?=(?:..|.(?&LINE)|(?&LINE){2}|....(?&LINE){3,})(?&LINE)(?&END))
|(?<=\n..)..(?=.+(?&LINE)(?&END))
|(?<=\n.)..(?=.+(?&LINE){2}(?&END))
|(?<=\n)..(?=.+(?&LINE){3}(?&END))
|(?:(?<=\n....)|(?<=^....))..(?=.+(?&LINE){4,}(?&END))/x
str = 'aaaaaaaaaaaaaaaaaaaa
aaaaaaaaaaaaaaaaaaaa
aaaaaaaaaaaaaaaaaaaa
aaaaaaaaaaaaaaaaaaaa
aaaaaaaaaaaaaaaaaaaa
aaaaaaaaaaaaaaaaaaaa
aaaaaaaaaaaaaaaaaaaa
aaaaaaaaaaaaaaaaaaaa
sdaffdsdfsdsfaadd
afdsafdsfssdsfdfs
afdsfdssdfdssfdsf
asfddsfafsdfdsdsf
asfdsdfafdsafasdf
hellohellohellohellohello
hellohellohellohellohello
hellohellohellohellohello
hellohellohellohellohello
hellohellohellohellohello
hellohellohellohellohello
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end