# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([0-9]+\.[0-9]+\.[0-9]+\.[0-9]+:[0-9]+\n)(?:^\1)+/$1/gm;t' <<< "172.27.0.1:22
172.27.0.1:21
172.27.0.1:23
172.27.0.1:23
172.27.0.1:23
172.27.0.1:25
172.27.0.1:25
172.27.0.1:24
"