import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([0-9]+\\.[0-9]+\\.[0-9]+\\.[0-9]+:[0-9]+\\n)(?:^\\1)+";
final String string = "172.27.0.1:22\n"
+ "172.27.0.1:21\n"
+ "172.27.0.1:23\n"
+ "172.27.0.1:23\n"
+ "172.27.0.1:23\n"
+ "172.27.0.1:25\n"
+ "172.27.0.1:25\n"
+ "172.27.0.1:24\n";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}