#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "href=\"(.*?)#watch#watch">"
Local $sString = "<a href="http://site.com/cinema/movies/32424_ttt_aaa/?autoplay=1#watch#watch">" & @CRLF & _
"<a href="http://site.com/cinema/movies/32424_ttt_aaa/?autoplay=1#watch#watch">" & @CRLF & _
"<a href="http://site.com/cinema/movies/32424_ttt_aaa/?autoplay=1#watch#watch">" & @CRLF & _
"<a href="http://site.com/cinema/movies/32424_ttt_aaa/?autoplay=1#watch#no">" & @CRLF & _
"<a href="http://site.com/cinema/movies/32424_ttt_aaa/?autoplay=1#yes#watch">"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")