const regex = /href=\"(.*?)#watch#watch">/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('href=\\"(.*?)#watch#watch">', 'g')
const str = `<a href="http://site.com/cinema/movies/32424_ttt_aaa/?autoplay=1#watch#watch">
<a href="http://site.com/cinema/movies/32424_ttt_aaa/?autoplay=1#watch#watch">
<a href="http://site.com/cinema/movies/32424_ttt_aaa/?autoplay=1#watch#watch">
<a href="http://site.com/cinema/movies/32424_ttt_aaa/?autoplay=1#watch#no">
<a href="http://site.com/cinema/movies/32424_ttt_aaa/?autoplay=1#yes#watch">`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}