$re = '/href=\"(.*?)#watch#watch">/';
$str = '<a href="http://site.com/cinema/movies/32424_ttt_aaa/?autoplay=1#watch#watch">
<a href="http://site.com/cinema/movies/32424_ttt_aaa/?autoplay=1#watch#watch">
<a href="http://site.com/cinema/movies/32424_ttt_aaa/?autoplay=1#watch#watch">
<a href="http://site.com/cinema/movies/32424_ttt_aaa/?autoplay=1#watch#no">
<a href="http://site.com/cinema/movies/32424_ttt_aaa/?autoplay=1#yes#watch">';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);