#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^/(?!dir(/?$|/dogs/|/lizards/)).*"
Local $sString = "/dir/cats" & @CRLF & _
"/dirpp/dogs" & @CRLF & _
"/dirg" & @CRLF & _
"/di" & @CRLF & _
"allowed:" & @CRLF & _
"/dir" & @CRLF & _
"/dir/" & @CRLF & _
"/dir/dogs/5"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")