re = /^\/(?!dir(\/?$|\/dogs\/|\/lizards\/)).*/m
str = '/dir/cats
/dirpp/dogs
/dirg
/di
allowed:
/dir
/dir/
/dir/dogs/5'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end