using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^/(?!dir(/?$|/dogs/|/lizards/)).*";
string input = @"/dir/cats
/dirpp/dogs
/dirg
/di
allowed:
/dir
/dir/
/dir/dogs/5";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}