import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?:LOTS?|LTS?) (\\w+(?:(?:\\s*[-,&])+\\s*\\w+)*)\\b";
final String string = "LT 75 CEDAR WOOD 3RD PL\n"
+ "LTS 22,25 & 26 MULLINS CORNER\n"
+ "LTS 7 & 8\n"
+ "PT LT 22-23 JEFFERSON HIGHLANDS EXTENSION\n"
+ "LTS 22, 25, & 26\n"
+ "LOTS 151, 162, & 164 PL 10-137 5 WILSON ST\n"
+ "LOTS 2A & 3B JACKSON HILL\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}