import re
regex = re.compile(r"\b(?:LOTS?|LTS?) (\w+(?:(?:\s*[-,&])+\s*\w+)*)\b", flags=re.MULTILINE)
test_str = ("LT 75 CEDAR WOOD 3RD PL\n"
"LTS 22,25 & 26 MULLINS CORNER\n"
"LTS 7 & 8\n"
"PT LT 22-23 JEFFERSON HIGHLANDS EXTENSION\n"
"LTS 22, 25, & 26\n"
"LOTS 151, 162, & 164 PL 10-137 5 WILSON ST\n"
"LOTS 2A & 3B JACKSON HILL\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")