$re = '/\b(?:LOTS?|LTS?) (\w+(?:(?:\s*[-,&])+\s*\w+)*)\b/m';
$str = 'LT 75 CEDAR WOOD 3RD PL
LTS 22,25 & 26 MULLINS CORNER
LTS 7 & 8
PT LT 22-23 JEFFERSON HIGHLANDS EXTENSION
LTS 22, 25, & 26
LOTS 151, 162, & 164 PL 10-137 5 WILSON ST
LOTS 2A & 3B JACKSON HILL
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);