package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\[[dtb]{1}\].*)$`)
var str = `[d] Did a Thing
[t] DOign a thing
[b] Blocked by a thing`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}