$re = '/(\[[dtb]{1}\].*)$/m';
$str = '[d] Did a Thing
[t] DOign a thing
[b] Blocked by a thing';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);