re = /(\[[dtb]{1}\].*)$/m
str = '[d] Did a Thing
[t] DOign a thing
[b] Blocked by a thing'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end