package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[a-zA-Z0-9\-_. ]{1,50}$`)
var str = `Role con espacios . - _
Role con espacios . - ?_
Role con espacios . - ,_`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}