re = /^[a-zA-Z0-9\-_. ]{1,50}$/m
str = 'Role con espacios . - _
Role con espacios . - ?_
Role con espacios . - ,_'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end