$re = '/^[a-zA-Z0-9\-_. ]{1,50}$/m';
$str = 'Role con espacios . - _
Role con espacios . - ?_
Role con espacios . - ,_';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);