using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=[^\w])[\d\.]+";
string input = @"SELECT pop1990, pop2000
FROM foo
WHERE pop1990 IN (5, 100, 7.8,25;)";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}