re = /(?<=[^\w])[\d\.]+/
str = 'SELECT pop1990, pop2000
FROM foo
WHERE pop1990 IN (5, 100, 7.8,25;)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end