$re = '/(?<=[^\w])[\d\.]+/';
$str = 'SELECT pop1990, pop2000
FROM foo
WHERE pop1990 IN (5, 100, 7.8,25;)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);