using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?i)(?<=[^\w])[-+]?[\d\.]+(e[-+]?\d+)?";
string input = @"SELECT pop1990, pop2000, 500, -50,-0.5, -5E-100, 4e+20, 3e10
FROM foo
WHERE pop1990 IN (5, 100, 7.8,25;)";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}