import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)(?<=[^\\w])[-+]?[\\d\\.]+(e[-+]?\\d+)?";
final String string = "SELECT pop1990, pop2000, 500, -50,-0.5, -5E-100, 4e+20, 3e10\n"
+ "FROM foo\n"
+ "WHERE pop1990 IN (5, 100, 7.8,25;)";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}