const regex = /(?i)(?<=[^\w])[-+]?[\d\.]+(e[-+]?\d+)?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?i)(?<=[^\\w])[-+]?[\\d\\.]+(e[-+]?\\d+)?', 'g')
const str = `SELECT pop1990, pop2000, 500, -50,-0.5, -5E-100, 4e+20, 3e10
FROM foo
WHERE pop1990 IN (5, 100, 7.8,25;)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}