import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "HKEY_\\S+(?=<\\/)";
final String string = "HKEY_LOCAL_MACHINE\\SYSTEM\\ControlSet002\\services\\Tcpip\\Parameters</span><br style=\"color:rgb(40,40,40);font-family:helvetica,arial,sans-serif;font-size:14px\"><span style=\"color:rgb(40,40,40);font-family:helvetica,arial,sans-serif;font-size:14px\">HKEY_LOCAL_MACHINE\\SYSTEM\\ControlSet002\\services\\Tcpip\\Parameters\\Interfaces\\{C3233060-B9BB-4DC1-8E2F-9E9306548D3D}</span><br style=\"color:rgb(40,40,40);font-family:helvetica,arial,sans-serif;font-size:14px\"><span style=\"color:rgb(40,40,40);font-family:helvetica,arial,sans-serif;font-size:14px\">HKEY_LOCAL_MACHINE\\SYSTEM\\CurrentControlSet\\services\\Tcpip\\Parameters</span><br style=\"color:rgb(40,40,40);font-family:helvetica,arial,sans-serif;font-size:14px\"><span style=\"color:rgb(40,40,40);font-family:helvetica,arial,sans-serif;font-size:14px\">HKEY_LOCAL_MACHINE\\SYSTEM\\CurrentControlSet\\services\\Tcpip\\Parameters\\Interfaces\\{C3233060-B9BB-4DC1-8E2F-9E9306548D3D}</span> <br></div>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}