import re
regex = re.compile(r"HKEY_\S+(?=<\/)", flags=re.MULTILINE)
test_str = "HKEY_LOCAL_MACHINE\\SYSTEM\\ControlSet002\\services\\Tcpip\\Parameters</span><br style=\"color:rgb(40,40,40);font-family:helvetica,arial,sans-serif;font-size:14px\"><span style=\"color:rgb(40,40,40);font-family:helvetica,arial,sans-serif;font-size:14px\">HKEY_LOCAL_MACHINE\\SYSTEM\\ControlSet002\\services\\Tcpip\\Parameters\\Interfaces\\{C3233060-B9BB-4DC1-8E2F-9E9306548D3D}</span><br style=\"color:rgb(40,40,40);font-family:helvetica,arial,sans-serif;font-size:14px\"><span style=\"color:rgb(40,40,40);font-family:helvetica,arial,sans-serif;font-size:14px\">HKEY_LOCAL_MACHINE\\SYSTEM\\CurrentControlSet\\services\\Tcpip\\Parameters</span><br style=\"color:rgb(40,40,40);font-family:helvetica,arial,sans-serif;font-size:14px\"><span style=\"color:rgb(40,40,40);font-family:helvetica,arial,sans-serif;font-size:14px\">HKEY_LOCAL_MACHINE\\SYSTEM\\CurrentControlSet\\services\\Tcpip\\Parameters\\Interfaces\\{C3233060-B9BB-4DC1-8E2F-9E9306548D3D}</span> <br></div>"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")