#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "HKEY_\S+(?=<\/)|(?=<br>)"
Local $sString = "HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\services\Tcpip\Parameters</span><br style="color:rgb(40,40,40);font-family:helvetica,arial,sans-serif;font-size:14px"><span style="color:rgb(40,40,40);font-family:helvetica,arial,sans-serif;font-size:14px">HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\services\Tcpip\Parameters\Interfaces\{C3233060-B9BB-4DC1-8E2F-9E9306548D3D}</span><br style="color:rgb(40,40,40);font-family:helvetica,arial,sans-serif;font-size:14px"><span style="color:rgb(40,40,40);font-family:helvetica,arial,sans-serif;font-size:14px">HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\Tcpip\Parameters</span><br style="color:rgb(40,40,40);font-family:helvetica,arial,sans-serif;font-size:14px"><span style="color:rgb(40,40,40);font-family:helvetica,arial,sans-serif;font-size:14px">HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\Tcpip\Parameters\Interfaces\{C3233060-B9BB-4DC1-8E2F-9E9306548D3D}</span> <br>HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\services\Tcpip\Parameters<br>HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\services\Tcpip\Parameters\Interfaces\{C3233060-B9BB-4DC1-8E2F-9E9306548D3D}<br>HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\Tcpip\Parameters<br>HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\Tcpip\Parameters\Interfaces\{C3233060-B9BB-4DC1-8E2F-9E9306548D3D}</p></"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")