# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"HKEY_\S+(?=<\/)|(?=<br>)"
test_str = "HKEY_LOCAL_MACHINE\\SYSTEM\\ControlSet002\\services\\Tcpip\\Parameters</span><br style=\"color:rgb(40,40,40);font-family:helvetica,arial,sans-serif;font-size:14px\"><span style=\"color:rgb(40,40,40);font-family:helvetica,arial,sans-serif;font-size:14px\">HKEY_LOCAL_MACHINE\\SYSTEM\\ControlSet002\\services\\Tcpip\\Parameters\\Interfaces\\{C3233060-B9BB-4DC1-8E2F-9E9306548D3D}</span><br style=\"color:rgb(40,40,40);font-family:helvetica,arial,sans-serif;font-size:14px\"><span style=\"color:rgb(40,40,40);font-family:helvetica,arial,sans-serif;font-size:14px\">HKEY_LOCAL_MACHINE\\SYSTEM\\CurrentControlSet\\services\\Tcpip\\Parameters</span><br style=\"color:rgb(40,40,40);font-family:helvetica,arial,sans-serif;font-size:14px\"><span style=\"color:rgb(40,40,40);font-family:helvetica,arial,sans-serif;font-size:14px\">HKEY_LOCAL_MACHINE\\SYSTEM\\CurrentControlSet\\services\\Tcpip\\Parameters\\Interfaces\\{C3233060-B9BB-4DC1-8E2F-9E9306548D3D}</span> <br>HKEY_LOCAL_MACHINE\\SYSTEM\\ControlSet002\\services\\Tcpip\\Parameters<br>HKEY_LOCAL_MACHINE\\SYSTEM\\ControlSet002\\services\\Tcpip\\Parameters\\Interfaces\\{C3233060-B9BB-4DC1-8E2F-9E9306548D3D}<br>HKEY_LOCAL_MACHINE\\SYSTEM\\CurrentControlSet\\services\\Tcpip\\Parameters<br>HKEY_LOCAL_MACHINE\\SYSTEM\\CurrentControlSet\\services\\Tcpip\\Parameters\\Interfaces\\{C3233060-B9BB-4DC1-8E2F-9E9306548D3D}</p></"
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.