using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"HKEY_\S+(?=<\/)|(?=<br>)";
string input = @"HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\services\Tcpip\Parameters</span><br style=""color:rgb(40,40,40);font-family:helvetica,arial,sans-serif;font-size:14px""><span style=""color:rgb(40,40,40);font-family:helvetica,arial,sans-serif;font-size:14px"">HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\services\Tcpip\Parameters\Interfaces\{C3233060-B9BB-4DC1-8E2F-9E9306548D3D}</span><br style=""color:rgb(40,40,40);font-family:helvetica,arial,sans-serif;font-size:14px""><span style=""color:rgb(40,40,40);font-family:helvetica,arial,sans-serif;font-size:14px"">HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\Tcpip\Parameters</span><br style=""color:rgb(40,40,40);font-family:helvetica,arial,sans-serif;font-size:14px""><span style=""color:rgb(40,40,40);font-family:helvetica,arial,sans-serif;font-size:14px"">HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\Tcpip\Parameters\Interfaces\{C3233060-B9BB-4DC1-8E2F-9E9306548D3D}</span> <br>HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\services\Tcpip\Parameters<br>HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\services\Tcpip\Parameters\Interfaces\{C3233060-B9BB-4DC1-8E2F-9E9306548D3D}<br>HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\Tcpip\Parameters<br>HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\Tcpip\Parameters\Interfaces\{C3233060-B9BB-4DC1-8E2F-9E9306548D3D}</p></";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}