package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^[a-z]+ [a-z]+, [a-z]{3}\d{1,2}-prt-([a-z]+-)?\d{1,3}$`)
var str = `word anotherword, xyz10-prt-otherword-500`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}