re = /^[a-z]+ [a-z]+, [a-z]{3}\d{1,2}-prt-([a-z]+-)?\d{1,3}$/
str = 'word anotherword, xyz10-prt-otherword-500'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end