const regex = /^[a-z]+ [a-z]+, [a-z]{3}\d{1,2}-prt-([a-z]+-)?\d{1,3}$/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[a-z]+ [a-z]+, [a-z]{3}\\d{1,2}-prt-([a-z]+-)?\\d{1,3}$', 'g')
const str = `word anotherword, xyz10-prt-otherword-500`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}