# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([^\n]+)/0\1/gm;t' <<< "01.текст
90. текст"